[Yum] rpmdb write File too large problem

Piavlo piavka at cs.bgu.ac.il
Tue Jun 15 22:13:04 UTC 2010


Hi James,

The problem was that in specific shell i run mistakenly
ulimit -f 1024
instead of
ulimit -n 1024
and forgot to set back ulimit -f
in the same shell later the yum commands started to fail
and that explains why speficically i got "1024: File too large"

Thanks
Alex


>> Any ideas how to solve the problem?
> 
>  'File size limit exceeded' is SIGXFSZ:
> 
> http://en.wikipedia.org/wiki/SIGXFSZ
> 
>  """ SIGXFSZ is sent to a process when it causes a file to grow larger
>      than the maximum allowed size, as determined by the ulimit system
>      call and shell builtin """
> 
> ...so try: "ulimit -f", and if it's not ulimited set it to that. Then
> try the --rebuilddb again.
> 



More information about the Yum mailing list