[Yum-devel] [PATCH 2/7] Add more makelists tests.
James Antill
james at fedoraproject.org
Thu Jul 18 13:30:00 UTC 2013
On Tue, 2013-07-16 at 12:19 -0400, Paul Nasrat wrote:
> On 16 July 2013 09:43, James Antill <james at and.org> wrote:
>
> > ---
> > test/simpleupdatetests.py | 102
> > +++++++++++++++++++++++++++++++++++++++++++--
> > 1 files changed, 98 insertions(+), 4 deletions(-)
> >
> > diff --git a/test/simpleupdatetests.py b/test/simpleupdatetests.py
> > index c485992..63b7e62 100644
> > --- a/test/simpleupdatetests.py
> > +++ b/test/simpleupdatetests.py
> > @@ -1080,7 +1080,7 @@ class SimpleUpdateTests(OperationsTests):
> > self.assert_(res=='ok', msg)
> > self.assertResult((pax2, pai2, pa2))
> >
> > - def testUpdateForDeps(self):
> > + def testUpdateForDeps0(self):
> >
>
> Personal bug bear on naming - Deps0 tells me nothing about what this is
> testing maybe more descriptive names - eg - testUpdateForDeps_userListed.
Yeh, I should put something else to group them into 3-4 sections. I
tend to get lazy with the unit test function names :).
> foo11 = FakePackage('foo', '1', '1', '0', 'i386')
> > foo11.addRequires('bar', 'EQ', ('0', '1', '1'))
> >
> > @@ -1097,7 +1097,101 @@ class SimpleUpdateTests(OperationsTests):
> > self.assertResult((foo12, bar12))
> >
> > self.tsInfo.makelists()
> > - for txmbr in self.tsInfo:
> > - print txmbr,
> > - print txmbr.reason
> >
>
> Yeah sorry for leaving the debugging prints in the original patch.
n/p ... was fine for seeing what was going wrong, only really "removed"
it as I'd tweaked it a lot and moved it around into the other unit tests
after I fixed yours :).
More information about the Yum-devel
mailing list