[Yum] Problem installing YUM on AIX

Rodrigo Belli rodrigobelli at gmail.com
Thu May 18 15:02:19 UTC 2017


The file exists in the directory :

server:/opt/freeware/lib/python2.7/site-packages/rpm$ ls -la
total 536
drwxr-xr-x    2 root     system         4096 May 18 09:20 ./
drwxr-xr-x    9 root     system         4096 May 18 10:39 ../
-rw-r--r--    1 root     system         2018 Feb 28 05:57 __init__.py
-rw-r--r--    1 root     system         2860 May 17 16:44 __init__.pyc
-rw-r--r--    1 root     system         1265 Feb 28 05:57 _rpmbmodule.la
-rw-r--r--    1 root     system        20187 Feb 28 05:57 _rpmbmodule.so
-rw-r--r--    1 root     system         1189 Feb 28 05:57 _rpmmodule.la
*-rw-r--r--    1 root     system       208888 Feb 28 05:57 _rpmmodule.so*
-rw-r--r--    1 root     system         1256 Feb 28 05:57 _rpmsmodule.la
-rw-r--r--    1 root     system         4234 Feb 28 05:57 _rpmsmodule.so
-rw-r--r--    1 root     system         5116 Feb 28 05:57 transaction.py




On Thu, May 18, 2017 at 11:41 AM Rich Niemi <rich.niemi at gmail.com> wrote:

> Could be problem where the libpython2.7.a is an archived library and yum
> cannot load it properly.
> May need to use ar to extract it to get a so lib to point yum to?
>
>
> On Thu, May 18, 2017 at 10:23 AM, Rodrigo Belli <rodrigobelli at gmail.com>
> wrote:
>
>> Hello, I'm starting with AIX and YUM and when tryed to use yum the
>> problem below was shown:
>>
>> server:/tmp/yum/bundle$ yum
>> There was a problem importing one of the Python modules
>> required to run yum. The error leading to this problem was:
>>
>>    Could not load module
>> /opt/freeware/lib/python2.7/site-packages/rpm/_rpmmodule.so.
>>         Dependent module /opt/freeware/lib64/libpython2.7.a(
>> libpython2.7.so) could not be loaded.
>>         The module has an invalid magic number.
>> Could not load module
>> /opt/freeware/lib/python2.7/site-packages/rpm/_rpmmodule.so.
>>         Dependent module
>> /opt/freeware/lib/python2.7/site-packages/rpm/_rpmmodule.so could not be
>> loaded.
>>
>> Please install a package which provides this module, or
>> verify that the module is installed correctly.
>>
>> It's possible that the above module doesn't match the
>> current version of Python, which is:
>> 2.7.13 (default, Jan 16 2017, 14:19:45) [C]
>>
>> If you cannot solve this problem yourself, please go to
>> the yum faq at:
>>   http://yum.baseurl.org/wiki/Faq
>>
>> Please, could anyone help me?
>>
>> Thanks in advance!
>>
>> Rodrigo
>>
>>
>> _______________________________________________
>> Yum mailing list
>> Yum at lists.baseurl.org
>> http://lists.baseurl.org/mailman/listinfo/yum
>>
>>
> _______________________________________________
> Yum mailing list
> Yum at lists.baseurl.org
> http://lists.baseurl.org/mailman/listinfo/yum
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.baseurl.org/pipermail/yum/attachments/20170518/f0ef5be2/attachment.html>


More information about the Yum mailing list