[Yum] Yum does not respect RPM dependency version constraints

Fabien Crespel fabien at crespel.net
Mon Dec 15 09:09:03 UTC 2014

Hello all,

I'm having issues with Yum dependency resolving with regards to dependent
package version constraints, on RHEL 6.5 with Yum 3.2.29.

In a PKG1 spec file, I have something like :
Requires: PKG2 >= 1.1.2-1
Requires: PKG2 < 1.2.0

In a Yum repo, PKG2 exists in several versions, among which 1.1.2-1 and
1.4.0-2, and PKG1 is in version 1.1.2-7

Here is what I see when running "yum install PKG1" :

--> Running transaction check
---> Package PKG1.noarch 0:1.1.2-7 will be installed
--> Processing Dependency: PKG2 < 1.2.0 for package: PKG1-1.1.2-7.noarch
--> Processing Dependency: PKG2 >= 1.1.2-1 for package: PKG1-1.1.2-7.noarch
--> Running transaction check
---> Package PKG2.x86_64 0:1.4.0-2 will be installed
--> Finished Dependency Resolution

Yum installs PKG2 1.4.0-2 instead of 1.1.2-1, thus does not respect the
"Requires" from PKG1.
I also tried with "Requires: PKG2 = 1.1.2-1" in PKG1, with the same
incorrect result.

Am I doing/understanding something wrong or is it a bug in Yum?

Thank you for your help,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.baseurl.org/pipermail/yum/attachments/20141215/5248c511/attachment.html>

More information about the Yum mailing list