[Yum] forcing older kernel package install (rpm --oldpackage for yum?)

Brian J. Murrell brian at interlinx.bc.ca
Wed Jun 13 13:17:33 UTC 2012


On 12-06-13 09:10 AM, James Antill wrote:
> 
>  This message is from rpm. Which means that yum/rpm is treating the
> "kernel" package as a normal package and not as an "installonly"
> package. Something seems badly configured.

I'm not entirely sure how to tell if yum is treating a package as
installonly or not but the transaction does show:

--> Processing Dependency: kernel = 2.6.32-220.17.1.el6_foo for package: bar-modules-2.1.2-2.6.32_220.17.1.el6_foo.x86_64.x86_64
...
---> Package kernel.x86_64 0:2.6.32-220.17.1.el6_foo will be installed

and the summary show:

Installing for dependencies:
 kernel            x86_64 2.6.32-220.17.1.el6_foo              foo   24 M

So it looks to me like yum is recognizing that it needs to "install"
that kernel package and not "upgrade" it.

Cheers,
b.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
URL: <http://lists.baseurl.org/pipermail/yum/attachments/20120613/e5688430/attachment.asc>


More information about the Yum mailing list