[Yum] required glibc-common = 2.12-1.25.el6 vs installed glibc-common-2.12-1.25.el6_1.3.x86_64
csieh at fnal.gov
Tue Nov 8 20:55:51 UTC 2011
On Tue, 8 Nov 2011, seth vidal wrote:
> On Tue, 8 Nov 2011 14:41:32 -0500
> "Terre Porter" <tporter at webpage-builders.com> wrote:
>> I'm not sure if this is a yum issue or just me being a bit brain dead.
>> I'm trying to install gcc on a Scientific Linux release 6.1 (Carbon)
>> box using yum but it keeps giving me the following error.
>> Error: Package: glibc-2.12-1.25.el6.i686 (sl)
>> Requires: glibc-common = 2.12-1.25.el6
>> Installed: glibc-common-2.12-1.25.el6_1.3.x86_64
>> (@sl-fastbugs/6) glibc-common = 2.12-1.25.el6_1.3
>> Available: glibc-common-2.12-1.25.el6.x86_64 (sl)
>> glibc-common = 2.12-1.25.el6
>> Anyone else having this problem, or know of how to fix it?
> 1. it looks like you have a newer version of glibc than what gcc in the
> sl 6.1 release has been built against
> 2. you should probably ping the scientific linux folks to see if this
> is a known repo issue
> Yum mailing list
> Yum at lists.baseurl.org
You need to enable the "fastbugs" repo as it seems you have installed the
glibc from that repo . The "fastbugs" repo has glibc-2.12-1.25.el6_1.3
and the "standard" repo has glibc-2.12-1.25.el6 .
yum --enablerepo=fastbugs install gcc
This will enable the fastbugs repo which has the glibc versions that you
have installed already.
Scientific Linux Developer
More information about the Yum