[Yum] required glibc-common = 2.12-1.25.el6 vs installed glibc-common-2.12-1.25.el6_1.3.x86_64

seth vidal skvidal at fedoraproject.org
Tue Nov 8 20:47:21 UTC 2011

On Tue, 8 Nov 2011 14:41:32 -0500
"Terre Porter" <tporter at webpage-builders.com> wrote:

> I'm not sure if this is a yum issue or just me being a bit brain dead.
> I'm trying to install gcc on a Scientific Linux release 6.1 (Carbon)
> box using yum but it keeps giving me the following error.
> Error: Package: glibc-2.12-1.25.el6.i686 (sl)
>            Requires: glibc-common = 2.12-1.25.el6
>            Installed: glibc-common-2.12-1.25.el6_1.3.x86_64
> (@sl-fastbugs/6) glibc-common = 2.12-1.25.el6_1.3
>            Available: glibc-common-2.12-1.25.el6.x86_64 (sl)
>                glibc-common = 2.12-1.25.el6
> Anyone else having this problem, or know of how to fix it?

1. it looks like you have a newer version of glibc than what gcc in the
sl 6.1 release has been built against
2. you should probably ping the scientific linux folks to see if this
is a known repo issue


More information about the Yum mailing list