[Yum] Security update/glibc name change seems to have confused yum

James Antill james-yum at and.org
Wed Jun 22 15:28:26 UTC 2011

PLD <sa212+sl6 at cyconix.com> writes:

> I have a new SL/RHEL6 installation, and yum is refusing to install gcc
> on it. As far as I can make out, a security update that I applied
> prior to my attempt to install gcc has caused problems. Any advice on
> this would be gratefully appreciated. Full story below.
> I now need to install the dev tools (g++, and so on), but I
> can't. I've tried this from gpk-application, and directly from
> yum. The complete yum output is below, but the basic error is:
>> Error: Package: glibc-2.12-1.7.el6.i686 (sl)

 Note the .i686

>>            Requires: glibc-common = 2.12-1.7.el6
>>            Installed: glibc-common-2.12-1.7.el6_0.5.x86_64 (@sl-security)
>>                glibc-common = 2.12-1.7.el6_0.5
>>            Available: glibc-common-2.12-1.7.el6.x86_64 (sl)
>>                glibc-common = 2.12-1.7.el6

...and the .x86_64 and not .i686. Note that sl-security is the
repo. that the newer version of glibc-common came from. Now:

> [root at foo work]# yum install gcc-c++
> Loaded plugins: refresh-packagekit
> epel/metalink                                            |  13 kB 00:00
> epel                                                     | 4.3 kB 00:00
> epel/primary_db                                          | 3.8 MB 00:16
> sl                                                       | 3.2 kB 00:00
> sl/primary_db                                            | 3.8 MB 00:11

 Note no sl-security repo.

> --> Processing Dependency: glibc-devel >= 2.2.90-12 for package:
> gcc-4.4.4-13.el6.x86_64

 But gcc requires this, which you don't have any version of.

> ---> Package glibc-devel.x86_64 0:2.12-1.7.el6 set to be updated
> --> Processing Dependency: glibc = 2.12-1.7.el6 for package:
> glibc-devel-2.12-1.7.el6.x86_64

 And this is the latest version available, which is older than the one
you have installed ... so yum tries to solve the problem by installing
the .i686 version ... but that doesn't work out.
 If you enable the sl-security repo. you should be able to get a
working version of glibc-devel, and all will be well.

James Antill -- james at and.org

More information about the Yum mailing list