[Yum] I want to share this experience

Muayyad AlSadi alsadi at gmail.com
Thu Jan 15 18:49:50 UTC 2009

I was trying to get the source rpm of wine-1.1.12-1.fc10.src.rpm
with yumdownloader --source wine

and here is the session

[root at pc1 alsadi]# yumdownloader --source wine
Loaded plugins: fastestmirror, kernel-module, priorities, refresh-packagekit,
              : remove-with-leaves
Loading mirror speeds from cached hostfile
 * fedora: mirror.ovh.net
 * rpmfusion-free-updates: mirror.karneval.cz
 * rpmfusion-nonfree-updates: mirror.karneval.cz
 * rpmfusion-free: mirror.karneval.cz
 * updates: mirror.ovh.net
 * rpmfusion-nonfree: mirror.karneval.cz
Enabling updates-source repository
Enabling rpmfusion-nonfree-updates-source repository
Enabling rpmfusion-nonfree-source repository
Enabling rpmfusion-free-updates-source repository
Enabling fedora-source repository
Enabling rpmfusion-free-source repository
No source RPM found for wine-1.1.12-1.fc10.i386
./wine-1.1.9-2.fc10.src.rpm already exists and appears to be complete

I cleaned the metadata with yum clean metadata
and tried again and again
and it did not work

I tried
wget http://download.fedoraproject.org/pub/fedora/linux/updates/10/SRPMS/wine-1.1.12-1.fc10.src.rpm
which redirected me here and there and 404 error

I tried again with wget and it worked

what do I want ?
any solution so this won't happen again
like getting the repomd.xml from a central point, it's just 2.8KB and
will never case denial of service attack

More information about the Yum mailing list