[Yum] yum fails to install most up to date version

James Antill james-yum at and.org
Tue Dec 8 13:19:37 UTC 2009


Maria Alandes Pradillo <Maria.Alandes.Pradillo at cern.ch> writes:

> Hi all,
>
> I have two repositories enabled with the following contents:
>
> Repo1:
> glite-VOBOX 3.2.1-0
> lcg-infosites 2.6.2-1
>
> Repo2:
> lcg-infosites 2.6.8-2
>
>
> glite-VOBOX has the following dependency:
> lcg-infosites >= 2.6.2-1
>
>
> If I run "yum install glite-VOBOX" I get lcg-infosites 2.6.2-1. However, if I get "yum update" later, I get lcg-infosites 2.6.8-2. Shouldn't I get the most up to date version from the beginning? Is this the expected behaviour?

 What version of yum is this?
 My guess is that something in compare_providers() decided the older
version was "better", which is unintended. Either that or there is
some missing information.

 Are glite-VBOX and lcg-infosites related in any other way (come from
the same .src.rpm etc.?)
 If you can run the install as:

    yum install glite-VOBOX -d 9

...then we should have enough information to tell you want happened,
and fix it.

-- 
James Antill -- james at and.org


More information about the Yum mailing list