[Yum] YUM Failing on 2 machines

Duncan Ritchie duncanr at pobox.com
Thu Jan 3 20:17:52 UTC 2008

I have been having issues with YUM on two FC7 boxes. It fails during the
loading of the primary.sqlite.bz2 files but it is not a consistent
repository that causes the issue.

I tried: Change the kernel, disable http_caching, yum clean all, yum clean
metadata, disabling some/all of the repo's.

Sometimes (very rare) it works but will fail the next time it is run.

The first box is running kernel and yum-3.2.8-2.fc7. It has
a number of additional repositories. I have tried disabling them and also
removing their config files.
Box two is running kernel 2.6.21-1.3194-FC7 and yum-3.2.0-1.fc7. This just
has the standard repos.

Here is the output from the first machine. 

[root at media1 ~]# yum update
Loading "kmdl" plugin
dries 100% |=========================| 951 B 00:00
fedora 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 3.8 MB 00:15
atrpms-in 100% |=========================| 951 B 00:00
updates 100% |=========================| 2.3 kB 00:00
primary.sqlite.bz2 100% |=========================| 2.2 MB 00:07
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
File "/usr/share/yum-cli/yummain.py", line 105, in main
result, resultmsgs = base.doCommands()
File "/usr/share/yum-cli/cli.py", line 287, in doCommands
File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in
self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in
pkgSack = property(fget=lambda self: self._getSacks(),
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 388, in
File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 352, in
File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 815, in
cur = cache.cursor()
AttributeError: 'NoneType' object has no attribute 'cursor'

The other machine looks much the same but with different line numbers.







-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.baseurl.org/pipermail/yum/attachments/20080104/fe81772d/attachment-0001.htm 

More information about the Yum mailing list