[Yum] --exclude does not work

Tim Lauridsen tla at rasmil.dk
Fri Mar 9 07:38:41 UTC 2007


Ray B wrote:
> I am running CentOS 4.x and the updates keep dieing
> at:
>
> Processing Dependency: libjasper-1.701.so.1 for
> package: ImageMagick
> --> Finished Dependency Resolution
> Error: Missing Dependency: libjasper-1.701.so.1 is
> needed by package ImageMagick
>
>
>
> i have tried the following combinations with zero
> luck:
>
> yum --exclude=foo update
> yum update --exclude=foo
> yum update --exclude=foo --exclude=foo_lib
> yum --exclude=foo --exclude=foo_lib update
>
> all of them give the EXACT same error as if i was not
> using the --exclude option.
>
> does not matter if i tell it to exclude ImageMagick,
> ImageMagic+libjasper, or libjasper it just keeps with
> the same BS.
>
>
>   
The issue here is that there is a installed package 'ImageMagick' the 
depends on 'libjasper-1.701.so.1'
The you running 'yum update' there is a package 'somepackage' there 
updates the 'libjasper' to another version og obsoletes it.
This can be done because it break the 'ImageMagick' dependency, it dont 
help to use '--exclude=ImageMagick' or '--exclude=libjasper'.
You have to use '--exclude=somepackage', because it is the package there 
introduce the issue.

Removing 'ImageMagick' also solves the issue.

Tim



More information about the Yum mailing list