[Yum] --exclude does not work

Ray B xindal at yahoo.com
Thu Mar 8 19:50:29 UTC 2007

I am running CentOS 4.x and the updates keep dieing

Processing Dependency: libjasper-1.701.so.1 for
package: ImageMagick
--> Finished Dependency Resolution
Error: Missing Dependency: libjasper-1.701.so.1 is
needed by package ImageMagick

i have tried the following combinations with zero

yum --exclude=foo update
yum update --exclude=foo
yum update --exclude=foo --exclude=foo_lib
yum --exclude=foo --exclude=foo_lib update

all of them give the EXACT same error as if i was not
using the --exclude option.

does not matter if i tell it to exclude ImageMagick,
ImageMagic+libjasper, or libjasper it just keeps with
the same BS.

so what is wrong with yum and why does it not do what
it is told, or is the man page wrong, or am i reading
it wrong?

Raymond L. Brunkow
Chief Instructor / Owner
Sun State Martial Arts
5th Degree Black Belt

Don't pick lemons.
See all the new 2007 cars at Yahoo! Autos.

More information about the Yum mailing list