[Yum] Http errors connection to repository

Stephens, Bill {PBSG} Bill.Stephens at pbsg.com
Tue Nov 14 19:15:30 UTC 2006


peplcm00003:/etc/yum.repos.d # yum install findutils-locate
yum install findutils-locate
Yum Version: 2.4.2
COMMAND: yum
Installroot: /
Ext Commands:
   findutils-locate
Setting up Install Process
Setting up repositories
Baseurl(s) for repo: ['http://devlinux.pbsg.pvt/sles10/']
http://devlinux.pbsg.pvt/sles10/repodata/repomd.xml: [Errno 14] HTTP
Error 502: Date: Tue, 14 Nov 2006 19:12:59 GMT
Content-Length: 1116
Content-Type: text/html
Server: NetCache appliance (NetApp/5.6.2D24)
Connection: close
Trying other mirror.
Cannot open/read repomd.xml file for repository: base
failure: repodata/repomd.xml from base: [Errno 256] No more mirrors to
try.
Error: failure: repodata/repomd.xml from base: [Errno 256] No more
mirrors to try.

peplcm00003:/etc/yum.repos.d # wget
http://devlinux.pbsg.pvt/sles10/repodata/repomd.xml
--13:13:22--  http://devlinux.pbsg.pvt/sles10/repodata/repomd.xml
           => `repomd.xml'
Resolving devlinux.pbsg.pvt... 156.81.226.112
Connecting to devlinux.pbsg.pvt|156.81.226.112|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 951 [text/xml]

100%[====================================>] 951           --.--K/s

13:13:22 (82.45 MB/s) - `repomd.xml' saved [951/951] 

-----Original Message-----
From: yum-bounces at lists.dulug.duke.edu
[mailto:yum-bounces at lists.dulug.duke.edu] On Behalf Of seth vidal
Sent: Tuesday, November 14, 2006 12:36 PM
To: Yellowdog Updater, Modified
Subject: Re: [Yum] Http errors connection to repository

On Tue, 2006-11-14 at 12:09 -0600, Stephens, Bill {PBSG} wrote:
> I have a repository configured on a local server.  When I connect to
the
> server using a baseurl of a local file (nfs mount), or by ip address,
> everything works fine.  If I try to connect to the same server by its
> cname or address name (a record), I get http 502 errors.  I can point
my
> web browser to the server and it works fine, it seems to be whenever I
> try to connect to the url by hostname rather than ip address.  Any
ideas
> what could be wrong?

on the machine you're trying to run yum on run this command:

wget $yourbaseurl_here

tell me what you get.

-sv


_______________________________________________
Yum mailing list
Yum at lists.dulug.duke.edu
https://lists.dulug.duke.edu/mailman/listinfo/yum



More information about the Yum mailing list