[Yum] Re: Re: yum 2.9 does no replacement in include=

Oliver Falk oliver at linux-kernel.at
Thu Jul 6 07:08:36 UTC 2006


On 07/05/2006 06:00 PM, yum-request at lists.dulug.duke.edu wrote:
> Just tested it here against CVS HEAD and it works for me; replacements 
> are done on the include URL. Can you supply the configuration files 
> you're using? Are there any error messages from Yum?

[of at somehost ~]$ cat /etc/yum.conf
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=0
plugins=1
metadata_expire=1800

include=http://<somehost>/<somescript>.pl?releasever=$releasever&arch=$arch&basearch=$basearch

[of at somehost ~]$ rpm -q yum
yum-2.9.2-1.noarch

It Fedora Core Development Tree, FYI.

On FC Devel I see the following:
[of at fcdev ~]$ yum check-update
_add_include main 
http://<somehost>/<somescript>.pl?releasever=$releasever&arch=$arch&basearch=$basearch
Setting up repositories

On FC5 I see the following:
[of at fc5 ~]$ rpm -q yum
yum-2.6.1-0.fc5
[of at fc5 ~]$ yum check-update
_add_include main 
http://<somehost>/<somescript>.pl?releasever=$releasever&arch=$arch&basearch=$basearch
_add_include main 
http://<somehost>/<somescript>.pl?releasever=5&arch=i686&basearch=i386
Setting up repositories

Config is the same for FC5 and FCDevel. I also have some AS4 U3 Machine 
here, where I compiled yum 2.9.2 srpm from fcdevel and the same happens 
- doesn't work.

-of

> Oliver Falk wrote:
>> Hi all!
>>
>> With yum 2.6, I was able to do
>>
>> include=http://somehost/somescript?releasever=$releasever&basearch=$basearch&arch=$arch 
>>
>>
>> but this doesn't work any longer.
>>
>> Can someone investigate, please!?



More information about the Yum mailing list