[Yum] Help: aborted 'yum upgrade' and corrupted rpm database resulted

Robinson Tiemuqinke hahaha_30k at yahoo.com
Fri Apr 28 23:07:24 UTC 2006


 Just encounts an odd problem with yum 2.4 on Fedora
Core 4: obsoleted rpms are not cleanup by yum when the
latter is killed and runs again.

 I tried to update the system the newest patch level,
it works at the beginning but suddently yum hangs --
most packages were updated with a few left.

 I had to kill the yum process and restart again, this
time it runs to the end and upgrade all the left

But when I tried to see what's in my rpm database, I
found that there are duplicate entries for all
packages upgraded before hang -- Yum doesn't cleanup
the old version info from rpm database because it
hanged and then be killed.

Any one know how to deal with this problem
effectively? I hate to list tens of obsoleted rpms one
by one and feed them to "rpm -e --justdb" command. 

If I don't clean up the obsoleted rpms from rpm
database, then next upgrade will definitely falls into

Please help.


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the Yum mailing list