[Yum] Bug: yum tries to update older version

Luis A. Florit yum at luisflorit.endjunk.com
Thu Apr 20 01:04:34 UTC 2006

Wow! What an active list!! :)
Let me answer all in one:

> > pilot-link.i386    1:0.12.0-0.pre4.5.2.1   core-freshrpms
> > pilot-link.i386    2:0.11.8-12.4.fc5       updates-freshrpm
> > pilot-link.i386    1:0.12.0-0.pre4.5.2.1   installed       
> > 
> >     Why does this happen? I think it has to do with the "2:" in
> > front of the version number, and have no idea why YUM puts this
> > in front! 
> Correct.  That's the package "epoch", which is like a super-version
> number.  It outranks all other version components.  This is not a yum
> bug.  Yum is doing exactly what it should.  You can take this up with
> your packagers if you like, but yum is acting properly.

Oh! I understand now. Sorry for calling it a bug.
The problem is that I found MANY times problems with dependencies under
epoch: a package A is build over version 1:... of package B that contains
the file C. Then it appears version 2:... with a different (or missing)
file C, yum tries to upgrade to the 2:..., but then there is a missing
dependency trying to upgrade B because file C needed by A. This is a
usual problem when mixing repositories.

> Just a few minutes ago, 'yum update' failed with the evolution dep,
> 'yum --exclude=evolution update' worked fine, and now 'yum update'
> is downloading an updated evolution.
> I guess this is just the mirrors not being fully synced yet.

Perhaps. But I found this problem with some packages that were never

> pilot-link was finally downgraded to the stable 0.11.8 version. FC4
> and FC5 used the 0.12-pre versions which weren't ready for release
> and caused all kinds of bugs.

Finally I understand what is this all about. Good.

> What dependency failures are you getting on downgrading pilot-link?

Missing Dependency: libpisock.so.9 for package: libmal
Missing Dependency: libpisock.so.9 for package: kdepim

I suppose libpisock.so.9 is contained in 1:0.12.0-0.pre4.5.2.1
and not in 2:0.11.8-12.4.fc5.

> All the packages in Core which require pilot-link have been rebuilt.
> In fact, the new evolution package was deployed to updates before
> the downgraded pilot-link package which caused problems for some
> people. Some of the Extras packages may need to be rebuilt. I had
> problems with the libopensync-plugin-palm package but I removed it
> because it was working anyway.

I solved it excluding pilot-link, and uninstalling gnome-pilot.
Too bad...

    But then, what to do in such a case? If I understood correctly,
the only solution is uninstalling some packages, or excluding the
update (in this case, of pilot-link)?

    Thanks a lot!!!


More information about the Yum mailing list