[Yum] Bug: yum tries to update older version

Ian Burrell ianburrell at gmail.com
Wed Apr 19 22:09:56 UTC 2006

On 4/19/06, Luis A. Florit <yum at luisflorit.endjunk.com> wrote:
>     I have a YUM recurring error since ages and never wasn't
> able to fix it.
>     I have 8 repositories, and YUM tries to update a package to an
> OLDER version. The command 'yum search pilot-link'returns this:
> pilot-link.i386    1:0.12.0-0.pre4.5.2.1   core-freshrpms
> pilot-link.i386    2:0.11.8-12.4.fc5       updates-freshrpm
> pilot-link.i386    1:0.12.0-0.pre4.5.2.1   installed
> Yum is trying to install the 0.11.8-12.4.fc5 version (??!!),
> that gives me error in dependencies and YUM doesn't update.
> 'yum list updates' shows pilot-link. I know how to prevent
> this, but only for each case, excluding the package in the
> update.
>     Why does this happen? I think it has to do with the "2:" in
> front of the version number, and have no idea why YUM puts this
> in front! I always treated this as a serious YUM bug, but it was
> never corrected. How to really prevent this?

The 2 is the epoch.  The epoch is a way to downgrade packages;
2:0.11.8-12.4.fc5 is considered newer than 1:0.12.0-0.pre4.5.2.1.

pilot-link was finally downgraded to the stable 0.11.8 version.  FC4
and FC5 used the 0.12-pre versions which weren't ready for release and
caused all kinds of bugs.

What dependency failures are you getting on downgrading pilot-link? 
All the packages in Core which require pilot-link have been rebuilt. 
In fact, the new evolution package was deployed to updates before the
downgraded pilot-link package which caused problems for some people.
Some of the Extras packages may need to be rebuilt. I had problems
with the libopensync-plugin-palm package but I removed it because it
was working anyway.

 - Ian

More information about the Yum mailing list