[Yum] Bug: yum tries to update older version

Luis A. Florit yum at luisflorit.endjunk.com
Wed Apr 19 22:01:38 UTC 2006


Pals,

    I have a YUM recurring error since ages and never wasn't
able to fix it.

    I have 8 repositories, and YUM tries to update a package to an 
OLDER version. The command 'yum search pilot-link'returns this:

pilot-link.i386    1:0.12.0-0.pre4.5.2.1   core-freshrpms
pilot-link.i386    2:0.11.8-12.4.fc5       updates-freshrpm
pilot-link.i386    1:0.12.0-0.pre4.5.2.1   installed       

Yum is trying to install the 0.11.8-12.4.fc5 version (??!!),
that gives me error in dependencies and YUM doesn't update.
'yum list updates' shows pilot-link. I know how to prevent
this, but only for each case, excluding the package in the
update.

    Why does this happen? I think it has to do with the "2:" in
front of the version number, and have no idea why YUM puts this
in front! I always treated this as a serious YUM bug, but it was
never corrected. How to really prevent this?

    Thank you very much for your time, 

        Luis.



More information about the Yum mailing list