[Yum] Proxy settings are ignored

Michael Stenner mstenner at ece.arizona.edu
Sat Apr 1 23:55:02 UTC 2006


On Sat, Apr 01, 2006 at 05:46:30AM -0800, sunset wrote:
> Could someone give some examples of correct proxy format in the yum.conf and
> / or .repo files ?
> 
> I've tried: (on FC5 that can connect to a wingate on winxp proxy).
> proxy=192.168.2.2
> proxy=192.168.2.2:80
> proxy=http://192.168.2.2
> proxy=http://192.168.2.2/
> proxy=http://192.168.2.2:80
> proxy=http://192.168.2.2:80/

These last two should work (and maybe the last four... not sure about
that).

> but though the internal proxy is working for web pages, yum always responds
> with:
> Setting up repositories:
> Core
> sits there for 30secs and then
> Cannot find a valid baseurl for repo: core
> Error: Cannot find a valid baseurl for repo: core.

I don't remember for sure about the error messages but this may be a
problem with your baseurl, not your proxy.  Can you post the .repo
file (or yum.conf if it's not in a .repo)?

> The wingate proxy logs all pages requested as well as active connections,
> but never sees an attempt from the machine in question. I can install /
> packet trace with ethereal or maybe I'm just doing something wrong ?

An ethereal trace would confirm/deny what I'm saying.  I suspect yum
is barfing on the url before it even tries it.

					-Michael
-- 
  Michael D. Stenner                            mstenner at ece.arizona.edu
  ECE Department and Optical Sciences Center                520-626-1619
  University of Arizona                                         ECE 524G



More information about the Yum mailing list