[Yum] Re: fc3 yum2.4.x installation problem

Mahmoud Trabelsi mahmoud.trabelsi at chello.at
Thu Oct 6 09:25:00 UTC 2005


Hi,

Tank You very much, I got it work.
I erased the 2.4.x rpm package installed installed this one -> 
yum-2.2.2-0.fc3.noarch.rpm
after I made this yum started working again.
Than I got another 2.4 package -> yum-2.4.0-5.py24.noarch.rpm from 
http://www.python.org/pyvault/
and tried to install it with rpm ... there were many dependendcies I 
resolved with yum 2.2.2.
after I did this I erased yum 2.2.2 again with rpm -e and installed the 
new one with rpm -i.

I hope that helps the people which want to do the same as I did :-)

Greetings TrabiGo

Greg Knaddison wrote:

>Hi,
>
>The error means that the yum module was not actually installed into
>the python path.
>
>I think you would be best served by removing whatever yum 2.4 rpm you
>installed and getting the yum RPM that was distributed with FC3 from
>one of the mirrors and installing that:
>
>
>rpm -e yourcurrentyumpakcagename
>wget ftp://linux.nssl.noaa.gov/fedora/core/3/i386/os/Fedora/RPMS/yum-2.1.11-3.noarch.rpm
>rpm -i yum-2.1.11-3.noarch.rpm
>
>
>If you really really really want yum 2.4 then you can download the yum
>2.4 binary from the yum website, rpmbuild --rebuild it, and then rpm
>-i that file.  However, I believe that you will then need to hand edit
>the yum.conf and yum.repos.d entries to fit your machine.
>
>Regards,
>Greg
>
>On 10/5/05, TrabiGo <trabigo at chello.at> wrote:
>  
>
>>Hi,
>>
>>I have tried to install yum with yum but that wasn't sucessfull so I
>>tried with the rpm's. I forced the installation of yum 2.4 and got this
>>following error msg:
>>
>>--------------------------------------------------------------
>>There was a problem importing one of the Python modules
>>required to run yum. The error leading to this problem was:
>>
>>   No module named yum
>>
>>Please install a package which provides this module, or
>>verify that the module is installed correctly.
>>
>>It's possible that the above module doesn't match the
>>current version of Python, which is:
>>2.4.2 (#1, Sep 28 2005, 10:20:51)
>>[GCC 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)]
>>
>>If you cannot solve this problem yourself, please send this
>>message to <yum at lists.linux.duke.edu>.
>>--------------------------------------------------------------------
>>
>>I also installed the actual python but what does "No module named yum"
>>mean ? I would be happy if someone can explain me this problem. Thank
>>you in advance.
>>
>>MfG TrabiGo
>>
>>_______________________________________________
>>Yum mailing list
>>Yum at lists.dulug.duke.edu
>>https://lists.dulug.duke.edu/mailman/listinfo/yum
>>
>>    
>>
>_______________________________________________
>Yum mailing list
>Yum at lists.dulug.duke.edu
>https://lists.dulug.duke.edu/mailman/listinfo/yum
>
>  
>




More information about the Yum mailing list