[Yum] possible bug

Nathanael Noblet nathanael at gnat.ca
Fri May 28 17:24:24 UTC 2004

    Before I submit a bug report I figured I'd email the list with the 
problem I am experiencing. I have a system recently installed 
(Tao-linux->RHEL 3.0 clone). Everything works normally as far as I can 
see. My problem comes from the fact that I want a new version of MySQL 
installed. I grabbed the official MySQL src rpms (4.0.18, and 4.0.20). 
Recompiled and installed via rpm -Uvh. No problems. Now when I do a yum 
update I get

... MySQL-Max requires MySQL >= 4.0

When it tries to do an update. The thing is I also recently migrated 
all 6 servers to this platform, and once they were installed, added my 
custom yum repository containing these compiled MySQL and a few other 
packages I needed. and installed them through yum by doing

yum install MySQL-shared MySQL-server... etc.

So for some reason it can resolve those dependancies on the rpm -Uvh 
install, and from a yum install (at least as far as I remember, it has 
been awhile so perhaps it didn't work there either I am current 
checking that). So I think there is a bug somewhere with this. I 
submitted a bug report to MySQL about the possibility of a problem in 
the spec file. The thing that makes me think this is a yum problem is 
that I can rpm -Uvh or rpm -i the files fine, and all dependancies are 
met. Only yum update has a problem.

One more thing. I took the spec file and did 2 things, once tried 
adding the requires to one of the packages. This didn't fix it. 
Removing the requirement made yum happy. BUT what happened after that 
was that it wanted to get the original mysql-3.2.x packages from the 
distros repo, so wasn't seeing the version numbers or something. I 
realize that this is case sensitive, but the mysql spec file contains 
both mysql and MySQL sections.

So I'm left wondering where the problem is. I figure it is a 
combination of spec file and yum (based on the fact that rpm -i doesn't 

System Specs:
yum-2.0.7 (I upgraded & tried again before posting)
rpm -q rpm = 4.2.2-0.14
uname -a = Linux 2.4.21-15smp #1 SMP Sun May 16 14:56:07 EDT 2004 i686 
i686 i386 GNU/Linux

Hope that gives you atleast enough information as a start. I'm willing 
to do everything I can to track down the true source of the problem and 
get it fixed.
Nathanael D. Noblet
Gnat Solutions
412 - 135 Gorge Road E
Victoria, BC V9A 1L1

T/F 250.385.4613


More information about the Yum mailing list