[Yum] bug in yum 2.0.5

seth vidal skvidal at phy.duke.edu
Wed Mar 3 21:27:15 UTC 2004


On Wed, 2004-03-03 at 23:13 +0200, Tuomo Soini wrote:

> I just enabled mysql support in postfix rpm. When I upgraded postfix 
> package on my test machines, I got errors because yum installed postfix 
> first and after postfix it installed mysql.

What do you mean "errors"
What type of errors.


> When postfix: Requires: mysql
> shouldn't yum install those req's first?

it installs them in the order rpm orders them in.

do you have the install output?


> Now package upgrade won't work correctly because mysql libs are missing 
> when postfix commands are run on %pre scriptlet to update old config to 
> new format.

This sounds like a broken package problem.

-sv





More information about the Yum mailing list