[Yum] i586 packages on an x86_64 machine

Jason L Tibbitts III tibbs at math.uh.edu
Thu Jun 10 13:42:34 UTC 2004


>>>>> "sv" == seth vidal <skvidal at phy.duke.edu> writes:

sv> maybe I'm crazy but is an i586 package ACTUALLY compatible with an
sv> x86_64?

The processor is completely binary compatible; you can install a
32-bit OS on it and things work fine.  I have plenty of i386 packages
and various 32-bit commercial applications running on my x86_64
machines.  FC2-x86_64 installs plenty of 32-bit packages, including
OpenOffice (which it seems isn't 64-bit clean yet).

I can install the j2re package from Dag's repository by hand without
problems, and I can at least run the "java" executable, but I have no
idea how to test it.

 - J<



More information about the Yum mailing list