[Yum] Re: update or upgrade?

Satish Balay balay at fastmail.fm
Fri Jan 23 15:42:45 UTC 2004



On Fri, 23 Jan 2004, Jeff Sheltren wrote:

> On Fri, 2004-01-23 at 05:50, seth vidal wrote:
> > On Fri, 2004-01-23 at 04:54, Tony Mountifield wrote:
> > > So why is "upgrade" deprecated in the man page, and threatened with
> > > future removal? It seems like pretty important functionality to me,
> > > when used correctly. I successfully used it to upgrade a RH9 box to FC1.
> > 
> > My plan is to add in an option to let it say --obsoletes.
> > 
> > 
> > so you can run: yum --obsoletes=[0|1] update
> > 
> > and we get rid of the confusion about update and upgrade. :)
> > 
> > does that make sense to you?
> > -sv
> 
> I think that having the obsoletes flag (or option in the config file)
> makes much more sense.

Perhaps it can be used at both locations. I personally prefer a
command-line version.

However I'd like to see this info '--obsoletes=[0|1] update' mentioned
in the yum-man-page where it says 'upgrade is depreciated'. Perhaps
something like:

*deprecated* - this command may be removed in the future - the
functionality is likely to be provided by 'yum --obsoletes=1 update'

thanks,
Satish



More information about the Yum mailing list