[Yum] Re: rpm-4.1.1 (needed for yum) install on RedHat 8

Axel Thimm Axel.Thimm at physik.fu-berlin.de
Sun Jan 11 22:15:18 UTC 2004


On Sun, Jan 11, 2004 at 10:34:39PM +0100, Alvaro Prudente wrote:
> I experience the following Problem when trying to install yum on RedHat8
> 
> when trying to install rpm-4.1.1 RedHat communicates a package conflict
> with the older rpm-4.1...
> I tried a forced install of the newer rpm but it didn't help.
> Any further Help, suggestions or experiences?:

Try -Uhv instead of -ihv (-U upgrade: install new and erase old package,
-i install: install new package, leave old packages there).

(Use -ihv only with kernel and kernel module rpms)

> Thank you
> 
> Alvaro
> 
> 
> 
> [root@]# rpm -ivh yum-2.0.3-5.rh.fr.i386.rpm
> Fehler: Failed dependencies:
>         rpm >= 4.1.1 is needed by yum-2.0.3-5.rh.fr
> [root@ ]# rpm -ivh popt-1.7.1-1.8x.i386.rpm rpm-4.1.1-1.8x.i386.rpm
> Preparing...                ###########################################
> [100%]
>         file /usr/include/popt.h from install of popt-1.7.1-1.8x
> conflicts with
> file from package popt-1.7-1.06
>         file /usr/lib/libpopt.a from install of popt-1.7.1-1.8x
> conflicts with file from package popt-1.7-1.06
>         file /usr/lib/libpopt.la from install of popt-1.7.1-1.8x
> conflicts with
> file from package popt-1.7-1.06
>         file /usr/lib/libpopt.so.0.0.0 from install of popt-1.7.1-1.8x
> conflicts with file from package popt-1.7-1.06
>         file /usr/share/man/man3/popt.3.gz from install of
> popt-1.7.1-1.8x conflicts with file from package popt-1.7-1.06
>         file /bin/rpm from install of rpm-4.1.1-1.8x conflicts with file
> from package rpm-4.1-1.06
>         file /usr/bin/rpm2cpio from install of rpm-4.1.1-1.8x conflicts
> with file from package rpm-4.1-1.06
>         file /usr/lib/librpm-4.1.so from install of rpm-4.1.1-1.8x
> conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/librpmbuild-4.1.so from install of rpm-4.1.1-1.8x
> conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/librpmdb-4.1.so from install of rpm-4.1.1-1.8x
> conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/librpmio-4.1.so from install of rpm-4.1.1-1.8x
> conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/athlon-linux/macros from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/i386-linux/macros from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/i486-linux/macros from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/i586-linux/macros from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/i686-linux/macros from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/macros from install of rpm-4.1.1-1.8x
> conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/noarch-linux/macros from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/rpmd from install of rpm-4.1.1-1.8x conflicts
> with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/rpmi from install of rpm-4.1.1-1.8x conflicts
> with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/rpmk from install of rpm-4.1.1-1.8x conflicts
> with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/rpmq from install of rpm-4.1.1-1.8x conflicts
> with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/rpmrc from install of rpm-4.1.1-1.8x conflicts
> with file from package rpm-4.1-1.06
>         file /usr/lib/rpm/tgpg from install of rpm-4.1.1-1.8x conflicts
> with file from package rpm-4.1-1.06
>         file /usr/share/man/ja/man8/rpm.8.gz from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/share/man/ja/man8/rpm2cpio.8.gz from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/share/man/man1/gendiff.1.gz from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/share/man/man8/rpm.8.gz from install of rpm-4.1.1-1.8x
> conflicts with file from package rpm-4.1-1.06
>         file /usr/share/man/man8/rpm2cpio.8.gz from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/share/man/pl/man8/rpm.8.gz from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/share/man/pl/man8/rpm2cpio.8.gz from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/share/man/ru/man8/rpm.8.gz from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/share/man/ru/man8/rpm2cpio.8.gz from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
>         file /usr/share/man/sk/man8/rpm.8.gz from install of
> rpm-4.1.1-1.8x conflicts with file from package rpm-4.1-1.06
> 
> _______________________________________________
> Yum mailing list
> Yum at lists.dulug.duke.edu
> https://lists.dulug.duke.edu/mailman/listinfo/yum

-- 
Axel.Thimm at physik.fu-berlin.de
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.baseurl.org/pipermail/yum/attachments/20040111/d383bf69/attachment-0001.pgp 


More information about the Yum mailing list