[Yum] keepalive=0 [was: retrygrab() failed ...]

David Relson relson at osagesoftware.com
Fri Jan 9 22:30:33 UTC 2004


On 09 Jan 2004 17:07:55 -0500
seth vidal <skvidal at phy.duke.edu> wrote:

> On Fri, 2004-01-09 at 16:28, David Relson wrote:
> > Summary:
> > 
> > without keepalive, couldn't get headers
> > with keepalive=0, got 1 header and failed on second header.
> > For completeness, tried keepalive=1.  Failed getting first header.
> 
> And you said you do or do not have a proxy in the way?
> 
> -sv

No proxies.  I run my own domain, firewall, etc and try to keep life
simple, if that's possible :-)

FWIW, wget works fine but yum check-update does not (see below):


[root at osage tmp]# wget -nd -c
http://mirrors.usc.edu/pub/yum-repository/mandrake/9.2/contrib/i586//headers/mindi-0-0.84-1mdk.noarch.hdr
--17:28:20-- 
http://mirrors.usc.edu/pub/yum-repository/mandrake/9.2/contrib/i586/headers/mindi-0-0.84-1mdk.noarch.hdr
           => `mindi-0-0.84-1mdk.noarch.hdr'
Resolving mirrors.usc.edu... done.
Connecting to mirrors.usc.edu[128.125.253.59]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2,364 [text/plain]

100%[====================================>] 2,364          2.25M/s   
ETA 00:00

17:28:21 (2.25 MB/s) - `mindi-0-0.84-1mdk.noarch.hdr' saved [2364/2364]

[root at osage tmp]# yum check-update
Gathering header information file(s) from server(s)
Server: Mandrake Linux 9.2 - Base
Server: Mandrake Linux 9.2 - Contribs
Server: Mandrake Linux 9.2 - Updates
Finding updated packages
Downloading needed headers
retrygrab() failed for:
 
http://mirrors.usc.edu/pub/yum-repository/mandrake/9.2/contrib/i586//headers/mindi-0-0.84-1mdk.noarch.hdr
  Executing failover method
failover: out of servers to try
Error getting file
http://mirrors.usc.edu/pub/yum-repository/mandrake/9.2/contrib/i586//headers/mindi-0-0.84-1mdk.noarch.hdr
[Errno 7] HTTP Error (CannotSendRequest): 
[root at osage tmp]# 



More information about the Yum mailing list