[Yum] yum client error (proxy problem?)

seth vidal skvidal at phy.duke.edu
Fri Jan 9 21:11:28 UTC 2004


On Thu, 2004-01-08 at 09:41, Kraszewski, Marcin wrote:
> yum-bounces at lists.dulug.duke.edu <> wrote on 7 January, 2004 18:18:
> 
> > On Wed, 2004-01-07 at 15:59, Kraszewski, Marcin wrote:
> >> Hi
> >> 
> [...]
> >> I am behind a proxy, so I created http_proxy variable. When I use
> >> just the "proxy_name:port#", I get the above error. I checked the
> >> archives and found a way to add userID and password, but when I tried
> >> providing user:password in that variable, I got an error about an
> >> invalid proxy port number. My proxy userID contains an '@' character,
> >> I think that causes the port number error. Is there a way to make yum
> >> client work on my network? TIA. 
> >> 
> 
> > pull down the latest yum daily from:
> > http://linux.duke.edu/yum/download/2.0/daily/
> > 
> > then set keepalive=0
> > under [main] in your yum.conf
> > 
> > tell me if it fixes the problem.
> > 
> > thanks
> > -sv
> 
> Hi, Seth
> 
> I was having network problems yesterday, but when all was well (networkwise)
> the error I got was:
> 
> [Errno 4] IOError: HTTP Error 407: Proxy Authorization Required
> 
> I tried to add "proxy-userid:passwd" to the http_proxy variable, but it does
> not work. My proxy userID contains an '@' character, so the variable looks
> like that:
> http_proxy="http://userid@domain:passwd@my-proxy:8080/" and I get the
> following error:
> 
> [Errno 7] HTTP Error (InvalidURL): nonnumeric port: 'passwd at my-proxy:8080'
> 
> I did what you suggested (updated yum and edited yum.conf), but am still
> getting the same errors. Is there a way around that problem? TIA
> 

/me grumbles  at urllib

this is a bug in urllib I'm fairly certain. 
It's a known bug, I think there might be a way around it but I can't
recall right now. You'll have to deal with it right now, I'm afraid.

-sv





More information about the Yum mailing list