[Yum] RedHat 2.1 ES FYI

Aaron P. Martinez ml at proficuous.com
Sat Aug 7 03:47:21 UTC 2004


Not sure if anyone is using it for this platform  (RedHat 2.1 ES), but I
am, and found that i was required to use the 1.x version of yum.....

I downloaded the src.rpm and built....but the resulting rpm had an 8 in
the name instead of a 7.x as the system seems to be built upon a mixture
of 7.2 and 7.3 redhat...  it seemed odd to me..but well...being the
accepting person i am..i said..hey.OK

trying to install was a nightmare.......it kept telling me i needed the
rpm 4.1 dependencies and i tried to fulfull them but to no avail...i,
like yum didn't want to force any installs so after realizing that 2.1
uses 4.0.x rpm i installed (instead of rebuilding) the src.rpm and took
out the librpm and rpm404 dependencies in the spec file then
rebuilt.....  then installed w/o a hitch.......  works like a charm...

Please, to all..let me know if i'm breaking something by doing
this......

Thanks in advance.

Aaron Martinez




More information about the Yum mailing list