[Yum] YUM

Michael Stenner mstenner at ece.arizona.edu
Fri Apr 16 17:10:46 UTC 2004

On Fri, Apr 16, 2004 at 05:20:51PM +0100, Peter Silva wrote:
> I am new to YUM and thought I'd give it a try. I have yum-2.0.6-1
> installed. I get the same error when I run any yum command :
> [root at canada etc]# yum update
> Gathering header information file(s) from server(s)
> Server: Fedora Core 1 - i386 - Base
> retrygrab() failed for:
> http://download.fedora.redhat.com/pub/fedora/linux/core/1/i386/os/headers/header.info
>   Executing failover method
> failover: out of servers to try
> Error getting file
> http://download.fedora.redhat.com/pub/fedora/linux/core/1/i386/os/headers/header.info
> [Errno 4] IOError: <urlopen error >
> [root at canada etc]# rpm -q yum
> yum-2.0.6-1
> [root at canada etc]#
> Can anyone shed some light ???

Hrm... I just tried that url myself and it seems to work ok.  The line
with "[Errno 4]" is really not more verbose?  That's all you get?

This is some sort of network error.  Try that link from the same
machine and see what you get.  Do this from the same machine:

python /usr/share/yum/urlgrabber.py http://download.fedora.redhat.com/pub/fedora/linux/core/1/i386/os/headers/header.info header.info

(all one line)

Also, use lynx or links or something and see what happens.

  Michael D. Stenner                            mstenner at ece.arizona.edu
  ECE Department, the University of Arizona                 520-626-1619
  1230 E. Speedway Blvd., Tucson, AZ 85721-0104                 ECE 524G

More information about the Yum mailing list