[Yum] Why is upgrade deprecated?

Tom Diehl tdiehl at rogueind.com
Fri Nov 21 15:27:10 UTC 2003


On Fri, 21 Nov 2003, Konstantin Riabitsev wrote:

> Tom Diehl wrote:
> > Would someone please explain why it would be a bad thing(tm) to do 
> > yum-update --with-obsoletes all of the time?? 
> 
> You could have two packages obsoleting each-other. This is, 
> actually, a real case, as zebra obsoletes gated, and gated obsoletes 
> zebra. If you did --with-obsoletes every time and had gated 
> installed, it would be replaced with zebra the next time yum runs. 
> Then with gated again. Then with zebra. Then with gated. Then with 
> zebra. Then with gated... :)

OK, I understand now.

Thanks to everyone who answered.

..................Tom



More information about the Yum mailing list