[Yum] Check conflicts; multiple archs

seth vidal skvidal at phy.duke.edu
Sat Mar 22 02:00:17 UTC 2003


On Fri, 2003-03-21 at 19:45, Axel Thimm wrote:
> I managed to get yum 1.8-20030307 running on RH8.0/rpm 4.2/python 2.2.1 (the
> bug with httplib was easy to fix by reducing the arguments, the other with
> coflicting epochs/versions I simply deleted the older package).
> 
> Now I am playing with building yum repositories, e.g. such from vanilla Red
> Hat 8.0. Since I want to understand everything I turn on all options:
> 
> > # yum-arch -l -d -c -z os
> > Checking deps 13 % completewarning: package glibc = 2.2.93-5 was already added, replacing with glibc <= 2.2.93-5
> > Checking deps 14 % completewarning: package glibc-debug = 2.2.93-5 was already added, replacing with glibc-debug <= 2.2.93-5
> > Checking deps 25 % completewarning: package kernel = 2.4.18-14 was already added, replacing with kernel <= 2.4.18-14
> > Checking deps 25 % completewarning: package kernel = 2.4.18-14 was already added, replacing with kernel <= 2.4.18-14
> > Checking deps 25 % completewarning: package kernel-smp = 2.4.18-14 was already added, replacing with kernel-smp <= 2.4.18-14
> > Checking deps 42 % completewarning: package openssl = 0.9.6b-29 was already added, replacing with openssl <= 0.9.6b-29
> > Checking deps 100 % complete[(('docbook-dtds', '1.0', '14'), ('openjade', '1.3.1'), 4, None, 1), (('glibc-common', '2.2.93', '5'), ('glibc', '2.2.93'), 4, None, 1)]

Also - I just did a check on rhl 8.0 stock tree - using -d -l -n and it
does a complete depcheck w/no errors.

one more thing -z is the default.

it's just left there in case someone had already enabled it in a script.

-sv





More information about the Yum mailing list