[Yum] Yum error question

seth vidal skvidal at phy.duke.edu
Mon Feb 24 20:00:12 UTC 2003


On Mon, 2003-02-24 at 11:41, Tom Diehl wrote:
> Hi all,
> I am trying to update a 7.2 machine with yum. The machine has a custom
> kernel rpm on it. when I try to do the update I get the following error:
> 
> Errors installing:
> ('package kernel-2.4.18-24.7.x.1.nano.tjc (which is newer than kernel-2.4.18-24.7.x) is already installed', (8, None, 0))
> [root at octopus root]#
> 

What command were you running?

What preceeds this error?
can you run it w/-d 4



> 1) should yum barf on this or should it just ignore the kernel in the 
> repository?

I'm not clear  the background here - can you fill in a bit more.


> 2) If yum is doing the correct thing what incantation do I need in the
> config file to get it to ignore the kernel rpms?

exclude=kernel* will exclude the kernel but I'd like to hear more about
what caused this problem.


-sv





More information about the Yum mailing list