[Yum] error report -- latest tarball yum-20030203.tar.gz (fwd)

seth vidal skvidal at phy.duke.edu
Tue Feb 4 04:40:51 UTC 2003


On Mon, 2003-02-03 at 16:38, R P Herrold wrote:
> On 3 Feb 2003, seth vidal wrote:
> 
> > So I think I know why you're having problems - you're attempting to run
> > this on rhl 8.0 - specifically on rpm 4.1. I'm not sure how to handle
> > this w/o making the code ugly with if statements.
> > 
> > But, I need a good way of getting people from psyche to phoebe+ cleanly.
> > hmm.
> 
> <smile> -- I feel your pain -- but really (please, please
> ...), coverage through each RPM point release seems necessary
> [rpm-4.1.x looks like it will be a Psyche only variant, with
> ].  Particularly, I am hoping to extend yum as a sub-tool in
> my SRPM auto-builder script project, and need it working
> genericly for Alpha and Sparc porting.
> 


ok then lets try it this way  - maybe as a part of the docs and I'll
gladly build rpms to meet all of these requirements:

I don't want to key off ver of rhl b/c the rpm ver can change inside it.

so lets base this off rpm version

rpm ver                         yum ver
4.0.4                           0.9.X 
4.1                             0.9.X with rpm404-python and librpm404
4.2				1.X or greater


Right now there are two branches of yum. There is the rpm 4 branch  and
the rpm 4.2 branch.

Would it be possible/reasonable to make it work this way? The headers
are still the same - yum-arch is almost identical in both (well, not
entirely, but close)


-sv





More information about the Yum mailing list