[Yum] error report -- latest tarball yum-20030203.tar.gz

R P Herrold herrold at owlriver.com
Mon Feb 3 20:16:35 UTC 2003


On 3 Feb 2003, seth vidal wrote:

> so - I'm not sure the solution - at the moment I'm inclined to say
> rhl 8.0 == you must use rpm4.0.4 libs.
> 
> I'll see what I can figure out.

grumble, grumble /// ummm ... I sent this earlier as to 
environment, and built from tarball ...

[root at ftp dl]# rpm -qa | grep rpm
rpm-python-4.1-1.06
librpm404-4.0.4-8x.27
rpm-build-4.1-1.06
rpm-4.1-1.06
[root at ftp dl]#

...
ncftp / > cd pub/mirror/redhat/redhat/8.0/i386/RedHat/RPMS/
ncftp ...t/8.0/i386/RedHat/RPMS > ls *librpm*
librpm404-4.0.4-8x.27.i386.rpm         
librpm404-devel-4.0.4-8x.27.i386.rpm

... ackkk --- librpm404-devel ---  My Bad for not seeing it.

It would be useful here (but not really generally in RPM
practice -- Repeat after me: 'it is just a packaging tool') to
permit differential 'Requires:' based on rpm version -- but
what a snake's nest to code for.  So, summarizing it has to be
BUILT against librpm404-devel IFF it is going to be installed
on a system with rpm 4.1.x .  Ouchhh.

Of course the build host cannot know, or infer where its 
product will later be installed.

Probably the best one could do is query rpm version at 
runtime, and then if == 4.1.x, set a flag, and if it faults 
out, catch and return a error message in the python code 
suggesting this as a possible issue.

Ickkk ...

-- Russ Herrold




More information about the Yum mailing list