[Yum] yum no longer working

seth vidal skvidal at phy.duke.edu
Wed Dec 24 21:13:51 UTC 2003

On Wed, 2003-12-24 at 13:52, Alex Olivas wrote:
> i'm getting the following error message when i try to use yum...
> Gathering header information file(s) from server(s)
> Server: Fedora Core 1 - i386 - Base
> Traceback (most recent call last):
>   File "/usr/bin/yum", line 60, in ?
>     yummain.main(sys.argv[1:])
>   File "yummain.py", line 188, in main
>   File "clientStuff.py", line 766, in get_package_info_from_servers
>   File "clientStuff.py", line 103, in HeaderInfoNevralLoad
> ValueError: unpack list of wrong size
> the last thing i did was kill a "yum info ..." with crtl-c.
> i tried "yum clean" (and variations) and also tried removing the
> files in /var/cache/yum.  i left the rpms alone though.
> any help would be greatly appreciated.

the header.info file for one of your repositories has been corrupted
and/or is returning a 403/404 error page but not the ACTUAL error.

look in /var/cache/yum/

look through all the dirs there and cat header.info in each dir.


More information about the Yum mailing list