[Yum] What to do if rpm download hangs

Cliff Kent cliff at villagevisions.com
Fri Dec 5 18:37:03 UTC 2003


I've had two instances, with different yum versions, but both on the 
same FC1 machine, of the rpm download stopping for a very long time.

Ok, downloads do fail. My internet connection is only live 99% of the 
time. So, I do manual updates.

What I did the first time was hit ctrl-c, wait 15 seconds, hit ctrl-c 
again. At that point the download appeared to restart and complete. Then 
yum exited. Without thinking, I ran yum update again and the new rpms 
were installed. Everything worked fine. But, I realized that the new rpm 
files had not been tested by yum.

The second time I tried to be smarter and deleted the "hung download" 
rpm before doing yum update again. I probably should have deleted all 5 
rpms, because they still did not all get tested.

All of which is background for questions:

1. how long will yum wait for a stalled download to complete?

2. what's the proper user reaction to this situation?

thanks,

Cliff Kent




More information about the Yum mailing list