[Yum] yum update error

Joe Cooper joe at swelltech.com
Sat Apr 19 18:28:52 UTC 2003

seth vidal wrote:
> On Sun, 2003-04-13 at 21:18, Darryl Caldwell wrote:

>>[root at skrewt darrylc]# yum update
>>Gathering package information from servers
>>Getting headers from: Red Hat Linux 8.0 rpms
>>Finding updated packages
>>Downloading needed headers
>>Resolving dependencies
>>Traceback (most recent call last):
>>  File "/usr/bin/yum", line 44, in ?
>>      yummain.main(sys.argv[1:])
>>        File "yummain.py", line 202, in main
>>	  File "nevral.py", line 263, in resolvedeps
>>	    File "archwork.py", line 63, in bestarch
>>	    IndexError: list index out of range
> Hi,
>  This is a bug. It's a known bug. It's fixed in cvs  - I'll have a new
> version up soon that corrects this then you don't have to worry about it
> - there is a patch available for this problem in the mailing list
> archives - if you want to apply it go for it.
> the fedora.us people have already applied it to their yum 1.95 rpm - you
> can grab that from here:
> http://download.fedora.us/fedora/redhat/9/i386/yum/stable/RPMS/yum-1.95-0.fdr.3.noarch.rpm
> 1.96 should be out before very long, though.

Hi Seth and all,

I ran into this problem this morning on Red Hat 8.0 running yum 1.0, 
when trying to upgrade to Red Hat 9.  It took me a while to figure out 
that the patch to fix this on 1.95 (from the fedora RPM) isn't the same 
patch that is needed to fix the same errors in yum 1.0, though the 
fedora nevralarch-dumb patch very nearly drops right into 1.0 (ok, you 
have to patch it manually, but it's obvious where it would go).  Anyway, 
I diff'ed the nevral.py from the 3/21 daily against 1.0 for the attached 
patch.  Seems to have worked (an upgrade is now in progress...I hope it 
isn't blowing up my desktop machine as we speak).

Seth, do you reckon  this patch covers everything that needs fixing in 
1.0 to address this error without breaking other stuff?
Joe Cooper <joe at swelltech.com>
Web caching appliances and support.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: yum-1.0-nevral-garbage.patch
Url: http://lists.baseurl.org/pipermail/yum/attachments/20030419/ddc4b88e/attachment-0001.diff 

More information about the Yum mailing list