[Yum] yum dep handling problem

Jack Neely jjneely at pams.ncsu.edu
Thu Oct 3 15:10:01 UTC 2002


Dan,

I believe you'll need to manually upgrade to RPM 4.0.4 before using YUM
like this.  I normally handle this problem by making the new rpm
packages availible for YUM to grab well in advance of any package that
needs rpm 4.0.4 features gets pushed into the tree.

HTH,
Jack Neely


On Wed, Oct 02, 2002 at 10:43:45PM -0600, Dan Burcaw wrote:
> Hi Seth,
> 
> I'm trying to upgrade a YDL 2.3 box (RH 7.2 ish)
> to a YDL 3.0 beta box (RH 8) and I see the following yum problems:
> 
> 
> Resolving dependencies
> package python needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package automake needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package e2fsprogs needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package bind-devel needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package tclx needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not provided)
> package bind needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not provided)
> package gcc-c++ needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package unzip needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package openldap-clients needs rpmlib(PartialHardlinkSets) <= 4.0.4-1
> (not provided)
> package tcl needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not provided)
> package emacs needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package gcc needs glibc-devel >= 2.2.90-12 (not provided)
> package gcc needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not provided)
> 
> package postgresql-contrib needs rpmlib(PartialHardlinkSets) <= 4.0.4-1
> (not provided)
> package gzip needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not provided)
> package procps needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package hfsutils needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package ncurses needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package tk needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not provided)
> package cdecl needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not
> provided)
> package perl needs rpmlib(PartialHardlinkSets) <= 4.0.4-1 (not provided)
> 
> 
> Now what is weird is newer version of the packages on the left side
> of all these lines are available!  And also, librpm404 provides the
> libary presumably needed.  Know what gives?
> 
> Thanks,
> -Dan
> _______________________________________________
> Yum mailing list
> Yum at lists.dulug.duke.edu
> https://lists.dulug.duke.edu/mailman/listinfo/yum
> 

-- 
Jack Neely <slack at quackmaster.net>
Linux Realm Kit Administration and Development 
PAMS Computer Operations at NC State University
GPG Fingerprint: 1917 5AC1 E828 9337 7AA4  EA6B 213B 765F 3B6A 5B89



More information about the Yum mailing list