[Yum] incorrect update list

seth vidal skvidal at phy.duke.edu
Tue Aug 27 21:43:42 UTC 2002


On Tue, 2002-08-27 at 16:30, Ma, Liang wrote:
> 
> Hi there,
> 
> I installed yum 0.9.2 on some of my RH 7.1, 7.2, 7.3 platforms. It works
> great until I tried to run 'yum update'.
> On rh 7.2, it reports that
> 
> package glibc needs glib-commom = 2.2.4-13 (not provided)
> 
> What I have currently installed 2.2.4-13 of glibc, glibc-commom and
> glibc-devel. In the update list yum picked up, there are only
> 2.2.4-29 of glibc-commom nd glibc-devel. For some reason glibc-2.2.4-29 is
> missing. I am sure glibc-2.2.4-29.i386.rpm is in my yum server, and even
> glibc-0-2.2.4-29.i386.hdr is created by yum-arch on the server. The same
> situation for openssl-0.9.6-13 on RH 7.1 and glibc again for rh7.3. Would
> anybody there point what the problem is here?
> 


run this command:

rpm -q --qf %{arch} glibc

I bet it reports i686

you need to make sure you pull in ALL the arch updates for glibc.

so if you look in red hat's updates tree you have updates/7.2/i386 and
i686 and athlon

thats important. yum is being pissy b/c glibc i386 is not better than
glibc i686 - and i686 is what you have installed.

I think this might be described as "correct behavior"


-sv



-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: This is a digitally signed message part
Url : http://lists.baseurl.org/pipermail/yum/attachments/20020827/ea55e97a/attachment-0001.pgp 


More information about the Yum mailing list