[PATCH] docs: Suggest "--" when using "show-installed --format yum". BZ 1027019

Zdenek Pavlas zpavlas at redhat.com
Wed Nov 6 13:27:15 UTC 2013


---
 show-installed.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/show-installed.py b/show-installed.py
index 4769092..caa0ef4 100755
--- a/show-installed.py
+++ b/show-installed.py
@@ -360,7 +360,7 @@ def __main__():
     parser = OptionParser(description="Gives a compact description of the packages installed (or given) making use of the comps groups found in the repositories.")
     parser.add_option("-f", "--format", dest="format",
                      choices=('kickstart','human','yum'), default="human",
-                     help='yum, kickstart or human; yum gives the result as a yum command line; kickstart the content of a %packages section; "human" readable is default.')
+                     help='yum, kickstart or human; yum gives the result as a yum command line; kickstart the content of a %packages section; "human" readable is default. Note that "--" should be added before the result when used as Yum argument to make sure excludes are not interpreted as options.')
     parser.add_option("-i", "--input", dest="input", action="store", default=None, help="File to read the package list from instead of using the rpmdb. - for stdin. The file must contain package names only separated by white space (including newlines). rpm -qa --qf='%{name}\\n' produces proper output.")
     parser.add_option("-o", "--output", dest="output", action="store", default=None, help="File to write the result to. Stdout is used if option is omitted.")
     parser.add_option("-q", "--quiet", dest="quiet", action="store_true", help="Do not show warnings.")
-- 
1.7.11.7



More information about the Yum-devel mailing list