[Yum-devel] multilib preference patch

seth vidal skvidal at fedoraproject.org
Tue Jan 29 21:07:10 UTC 2008


On Tue, 2008-01-29 at 16:02 -0500, seth vidal wrote:
> With the help of Tim and James A. I have a patch which lets the user
> select what will happen when they are on a multilib arch and they do an:
> install foo or install foo* as to which archs it will install by
> default.
> 
> the config parameter is multilib_policy and it's options are best and
> all.
> 
> all == the behavior yum has always had - which is to install all archs
> it can (ie: i386 and x86_64)
> 
> best == install only the 'best' arch for that architecture. So on x86_64
> it is x86_64, on ppc64 it should be ppc, on sparc64 it is is sparcv9,
> etc
> 
> The default is 'all'
> 
> This patch also handles removing ia64 as multilib arch b/c it no longer
> is one.
> 
> It also deals with a small problem with the earlier rpmsack patch from
> Florian. 
> 
> I feel like we probably want this, but I'm open to opinions.
> 

yes and the patch is here:

http://skvidal.fedorapeople.org/patches/yum-bestarch-multilib.patch

-sv





More information about the Yum-devel mailing list