[Yum-devel] groupreq in yum-2.6?

seth vidal skvidal at linux.duke.edu
Sat May 13 18:53:45 UTC 2006


On Sat, 2006-05-13 at 14:44 -0400, Russell Harrison wrote:
> I should point out that mock builds are broken currently on FC5
> because it uses yum 2.6.  groupreq is used by the fedora extras build
> environment to include various levels of builds.  When mock initiates
> the chroot it does a "yum groupinstall build" which should pull in
> build-base and build-minimal, and doesn't on FC5 machines. 

there is a line in your mock config files which looks like this:
config_opts['buildgroup'] = 'build'


make it read:

config_opts['buildgroup'] = 'build build-minimal build-base'

then it will all work.

-sv








More information about the Yum-devel mailing list