[Yum-devel] yum 2.1.3

seth vidal skvidal at phy.duke.edu
Mon Sep 20 18:40:35 UTC 2004


On Mon, 2004-09-20 at 14:31, Michael Jennings wrote:
> On Monday, 20 September 2004, at 02:13:20 (-0400),
> seth vidal wrote:
> 
> > What version of rpm is this? and what ver of python?
> 
> rpm-4.2.1-10.caos

Does the same thing happen on rpm 4.2.2?

> python-2.3.3-8.caos
> 
> > The reason I'm distressed is that where it is erroring is:
> > 
> > for te in self.ts:
> > 
> > it's claiming self.ts is not an iteratable object.
> > 
> > And it REALLY should be :)
> 
> Well, I'm no Python guru, but it looks like you're wanting to iterate
> over the transaction set.  Seems perfectly reasonable to me. :]
> 
> I can boost the debugging if needed.

how about rpm-python version?


let's try a VERY simple case, too:
run python
>>> import rpm
>>> ts = rpm.TransactionSet()
>>> ts.addErase('yum')
>>> for te in ts:
...     print te.N()

press enter twice.

tell me what you get.

-sv







More information about the Yum-devel mailing list