[Yum-devel] Re: repoquery/yum vs python version requirements

seth vidal skvidal at phy.duke.edu
Sun Sep 12 18:19:15 UTC 2004


On Sun, 2004-09-12 at 20:01 +0300, Panu Matilainen wrote:
> Hi,
> 
> Any thoughts on python version requirements of repoquery - is it ok to use
> python 2.3 features or should repoq run with older pythons as well? Namely
> I'd like to use optparse which is only available in 2.3. I'll survive with
> getopt but somehow I have this feeling repoquery is going to be rather
> heavy on various options and optparse would be nicer for that...

I'm inclined to worry about platforms like rhel 3 - which could use the
repodata style repositories but don't have python 2.3.

having said that making a requirement of optparse under 2.2 isn't
unthinkable.

I'm inclined to say go for it - but I would not suggest using 
from future import.... :)

-sv






More information about the Yum-devel mailing list