[Rpm-metadata] createrepo multiple group files did not work

jupiter jupiter.hce at gmail.com
Tue Jul 31 06:33:48 UTC 2012


Hi,

I am new to the list, is it a right list to ask following question? If
I posted to a wrong list, could you please point me where should I
post following question to?

Thank you.

Kind regards.

On 7/27/12, jupiter <jupiter.hce at gmail.com> wrote:
> Hi,
>
> I am running createrepo version 0.9.8 and yum version 3.2.29 on CentOS
> 6.2 where I created a private repository.
>
> I have been baffled by following issues.
>
> It works if I run only one group file "createrepo -g group1.xml
> repo_directory". When I run second group file "createrepo -g
> group2.xml repo_directory", the "yum grouplist" can only see group2,
> not group1 any more. It seems that the later command "createrepo -g
> group2.xml repo_directory" generated metadata overwriting and removing
> the previous group1 metadata. Is it a bug or what I could do wrong?
> Appreciate any helps to fix multiple group file metadata in
> repository.
>
> Thank you.
>
> Kind regards,
>
> Jupiter
>


More information about the Rpm-metadata mailing list