[Rpm-metadata] Yum server installation - repomd.xml - cannot file the file speci fied.

Paradis, Irene (TRAC) irene.paradis at us.army.mil
Mon Mar 27 23:50:07 UTC 2006

I got the problem fixed (with a fresh pair of eyeballs to help me out).  I
didn't realize the *xml file (among others) needs to be created by running
"createrepo".  I had to download the "createrepo" rpm file.  That was my
first problem.  Then, I also had the IP address wrong in my yum.conf.  When
I tried a test "ftp" to the IP address I was using in yum.conf, I noticed
"ftp" thought I was going to a Windows machine, and I knew I wasn't.  Once I
straightened that out, it works now.


-----Original Message-----
From: rpm-metadata-bounces at lists.dulug.duke.edu
[mailto:rpm-metadata-bounces at lists.dulug.duke.edu] On Behalf Of Paul Nasrat
Sent: Monday, March 27, 2006 1:43 PM
To: rpm-metadata at lists.dulug.duke.edu
Subject: Re: [Rpm-metadata] Yum server installation - repomd.xml - cannot
file the file speci fied.

On Mon, 2006-03-27 at 13:33 -0700, Paradis, Irene (TRAC) wrote:
> I'm trying to install a YUM server on a network that cannot touch the 
> Internet.  I've downloaded "yum-2.4.0.tar.gz" and installed it.  I 
> have an "/etc/yum.conf" file.  The machine is running RHEL 4.  When I 
> run "yum update" I get the following error.  NOTE, I'm replacing the 
> IP address since it is not public:
> IOError : [Errno ftp error] 550 pub: The system can not find the file 
> specified.

Please attach your repo config for the repo in question.


Rpm-metadata mailing list
Rpm-metadata at lists.dulug.duke.edu

More information about the Rpm-metadata mailing list